End User License Agreement (EULA)

Hot CPU Tester Pro 3 Lite Edition

Copyright (C) 1999-2002 7Byte Computers, Inc.

Web: www.7byte.com

Email: info@7byte.com

This End User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and 7Byte Computers, Inc. ("7Byte") for the product known as Hot CPU Tester Pro 3 Lite Edition, which may include online or electronic documentation ("Software").

If you do not agree to all of the terms of this agreement, you may not use or continue to use this software.

SCOPE OF GRANT

This EULA grants you the following, non-exclusive rights:

You may:

  • Re-distribute it freely without making any profit of it.

You may not:

· Permit other individuals and company to use the Software except under the terms listed above

· Modify, translate, reverse engineer, decompile, and disassemble the Software

· Distribute the Software other than as specified above

· Remove or edit any proprietary notices or labels on the Software

· Take any credit for it

COPYRIGHT

All rights, title and copyrights in and to the Software (including any images, photographs incorporated into the Software) and any copies of the Software, are owned by 7Byte or its suppliers. The Software is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. Therefore, you must treat the Software like any other copyrighted material except that you may make one copy of the Software solely for backup or archival purposes. The Software is licensed, not sold.

TITLE

Title, ownership rights, and intellectual property rights in the Software shall remain in 7Byte and/or its suppliers. The Software is protected by the copyright laws and treaties.

TERMINATION

The license will terminate automatically if you fail to comply with the limitations described herein. On termination, you must destroy all copies of the Software including accompanying documentation.

DISCLAIMER OF WARRANTY

This Software is provided on an "AS IS" basis, without warranty of any kind, including without limitation the warranties of merchantability, fitness for a particular purpose and non-infringement. This Software has inherent limitations including design faults and programming bugs. You must use trial version to ensure that the product meets your needs and is fit for the purpose for which you intend to use it. This means that the entire risk as to the quality and performance of the Software is borne by you. Should the Software prove defective, you and not 7Byte assume the entire cost of any service and repair. This disclaimer of warranty constitutes an essential part of the agreement. Some jurisdictions do not allow exclusions of an implied warranty, so this disclaimer may not apply to you and you may have other legal rights that vary by jurisdiction.

The vary nature of this Software is of System Utility and should be used with utmost care and precaution.

LIMITATION OF LIABILITY

Under no circumstances and under no legal theory, tort, contract, or otherwise, shall 7Byte or its suppliers or resellers be liable to you or any other person for any indirect, special, incidental, or consequential damages of any character including, without limitation, damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses. In no event will 7Byte be liable for any damages in excess of the amount 7Byte received from you for a license to the software, even if 7Byte shall have been informed of the possibility of such damages, or for any claim by any other party. This limitation of liability shall not apply to liability for death or personal injury to the extent applicable law prohibits such limitation. Furthermore, some jurisdictions do not allow the exclusion or limitation of incidental or consequential damages, so this limitation and exclusion may not apply to you.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

To the maximum extent permitted by applicable law, in no event shall 7Byte or its suppliers be liable for any damages whatsoever (including, without limitation, damages for loss of business profit, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of the inability to use this product.

WAIVER OF RESPONSIBILITY FOR MISUSE

The Software can process copyright material and has no way of knowing if such processing is in breach of copyright law. You agree that it is your responsibility to ensure that you only process material for which you own or have licensed the copyright and, further, to indemnify and hold harmless 7Byte from any claim whatsoever relating to your improper use of the Software to process copyright materials.


Who needs Hot CPU Tester?

7Byte’s Hot CPU Tester is a software tool that allows all the major sub-systems of a computer to be simultaneously tested for reliability and stability. Anyone who has used computers for any period of time knows the importance of having a stable system. The cost of a hardware failure can be enormous. If you are lucky your data will only become inaccessible while faulty components are replaced. If you’re unlucky you can lose your files completely or have them permanently corrupted. Even if you have good backups, you can still lose days of work returning the PC to its pre-failure state. In many cases the lost data can never be replaced and businesses can be brought to their knees, with the loss of documentation, customer details and financial records.

What Hot CPU Tester does is thoroughly exercise the hardware in a PC in a short period of time, in the same way as normal applications use a PC over a long period of time. This takes advantage of the fact that computer hardware tends to fail either very early in its life or after many thousands of hours of use.

Typically Hot CPU Tester should be used before a PC is put into service, as a failure of a computer that isn’t being used for a critical application and doesn’t have any critical data is much less damaging, (specially if it is still under warranty).
Hot CPU Tester will bring to the surface intermittent or hidden problems so that after a successfully run the computer can be used with a much higher level of confidence.

Hot CPU Tester Pro tests the CPU via mathematical operations, MMX, SSE, SSE2 & 3DNow! calculations, Mother board, L1 cache, L2 cache, and Memory. All these tests can be done simultaneously as the application is multithreaded.

Therefore, almost everybody needs Hot CPU Tester. It is a very reliable burn in test program in the market, which is used by some government organizations & many companies around the world.

Copyright 1999 - 2002 7Byte Computers, Inc. - All rights reserved


Hot CPU Tester

Hot CPU Tester Pro 3 (Lite Edition)

Copyright (C) 1999-2002 7Byte Computers, Inc.

www.7byte.com

info@7byte.com

Hot CPU Tester Pro is a system stability tester. It tests CPU, and virtually all parts of motherboard units for errors. It is a burn in test with unique DefectTech engine. DefectTech is a technology developed by 7Byte to diagnostic systems regarding its stability and in general computer's health. It is currently being used in many governmental organizations and labs around the world, as a reliable stability testing utility.

Warning: this computer program is protected by copyright law and international treaties. Unauthorized use, reproduction, or distribution of this program, or any portion of it, is prohibited.

All trademarks & registered trademarks are properties of their respective owners.


Diagnostic

-Modules:

This section shows each module's progress during the test. Each 3 box inside the progress bar represents a cycle of the testing module.
-Diagnostic:

This section has the main program button 'Run/Stop' which runs the test or stops it. It also shows tests timing (Elapsed time, etc.)
-CPU Performance:

This section monitors the CPU while it is under pressure through a graph. Basically, this graph measures CPU speed while its under pressure with its idle time, and takes it percentage. Normally, it should be between 90% to 100%. Sometimes, it might go under 20% which maybe cause of interfering other programs or even Windows itself. This graph and its measures doesn't measure systems quality, health, etc.


Benchmark

Note: All results are relative to this program and they may be different in other benchmarking programs.
-Integer Benchmarks:

This section shows the benchmark result of integer processing. All numbers are in Million Instructions Per Second.
-Floating-Point Benchmarks:

This section shows the benchmark result of floating-point processing. All numbers are in Million Floating-Points Instructions Per Second.
-MMX/MMX2 Benchmarks:

This section shows the benchmark result of MMX/MMX2 processing. If CPU supports MMX2 instructions it automatically measures MMX2 instructions as well as MMX. All numbers are in Million MMX Instructions Per Second.
-SSE/SSE2 Benchmarks:

This section shows the benchmark result of SSE/SSE2 processing. If the computer supports SSE2 instructions it automatically measures SSE2 instructions as well as SSE. All numbers are in Million SSE Instructions Per Second.
-3DNow! Benchmarks:

This section shows the benchmark result of 3DNow! processing. All numbers are in Million 3DNow Instructions per second.
-Memory Benchmarks:

This sections benchmarks Memory. It depends on CPU speed, Memory itself, memory bus, chipsets and etc. All numbers are in MB per Second.
-Print:

Prints the benchmark results.


Certification

A "Hot CPU Tester certificate" is a digital signature, which verifies stability of a system has been tested by Hot CPU Tester and is stable under hard conditions. You can issue a Certificate after 6 hours or more of testing system with Hot CPU Tester in Smart mode
-Validate a certificate:

Verifies a "Certificate" on the computer. A certificate is only valid for 1 month after that it will be voided. And it is only valid as long as you don't change anything on the system.
-Issue a certificate:

Issues a "Certificate". Hot CPU Tester has to be run prior for 6 hours with Smart detect on.


CPUID

-Processor selection:

  • Total system processors): The total number of system processors.

  • Processors) available to this process: The total number of available processor to this process. The system might have more than one processor but unavailable to this process.
-Processor:

Displays CPU's information. Clock speed might be vary every time(±10Mhz), since the program counts it manually. It calculates the exact speed of CPU, note that the CPU speed might not be very accurate on some mobile processors, this is not a program bug.
-Cache:

Displays information about Internal and External Cache.
-Feature Flag:

This Button Displays CPU's Feature flags, which are some detailed information about the CPU.


Live Support

- Auto Update:

Checks for a newer version of Hot CPU Tester.
- Contact Hot CPU Tester's support team: [Note: This option is not available in the Lite Edition]

With this option you are able to ask for assistance from Hot CPU Tester support team regarding your system status/problems. Shortly, after submitting your information ,by pressing the Submit button, to OpusWare you will receive a reply from us regarding to your concerns questions problems. Make sure to enter a correct email address. That is how we can contact you, and please specify your question/problem and/or any other additional information in the Additional info & comments field


Options

- Options:

You can chose a category from here to set Hot CPU Tester options.

  • Hot CPU Tester

  • Testing Modules

  • Benchmarks

  • LiveSupport


Hot CPU Tester Options

-Instructions set:

  • Active Libraries: Displays the active libraries Hot CPU Tester is using. Hot CPU Tester is optimized for the following processors and would use the proper optimized library on them:
    -Intel Pentium
    -Intel Pentium Pro
    -Intel Pentium II
    -Intel Pentium III
    -Intel Pentium 4
    -AMD K6 - 2
    -AMD K6 - 3
    -AMD Athlon processors (Duron, Thunderbird)
    -AMD Athlon XP

  • DefecTech: Displays if DefecTech is enabled. Normally, it has to be enabled unless DefecTech engine cannot detects CPUs specialized features.

-General:

  • Enable logging: Enables or disables the logging window. This option only disables the logging window, however it still records information in the logging file at "C:\HCT.Log". Hot CPU Tester limits the log file to 100KB. Note that it requires you to restart the program, in order to takes effect.

  • Enable visual effects: Enable or disables the visual effects for Hot CPU Tester.


Testing Modules Options

-Diagnostic Mode:

  • Smart Detect: Automatically, sets all the features on your system according to your system options and components. This option is recommended to all users, because Hot CPU Tester uses sets its feature optimally to tests the system. This option must be enabled in order to issue a certification.

  • Burn-in: Sets all the features so the CPU (and other components as well) generates maximum heat. Users should be aware that this option stresses components to their maximum limits.

  • Custom: Enables custom mode. Only in this mode user can enable/disable modules and their priorities.

-Testing Time:

Sets testing time, in Manual mode user can enter number of hours to tests the system. (Can be changed only in Custom mode)

-Process priority:

Sets process priority. Note that in Realtime! your system might become unusable as Hot CPU Tester would use all system resources. (Can be changed only in Custom mode only)


Modules Options-

Testing Modules Options

-(Module name):

  • Enabled: enables the module. [Can be changed only in custom mode]

-Thread priority:

  • Sets the priority thread( or in this case module's priority). [Can be changed only in custom mode]

-Active prosessors:

  • Sets CPU(s) affinity mask. [Can be changed only in custom mode]


Benchmarking Options

Benchmark Options

-Benchmarks set:

Let user enables or disables Benchmarks set to run.

-Benchmarks precision:

Sets benchmarking precision. Has 3 degree, Low, Medium and High. Low is fastest and High is the slowest setting.


Live Support Options

-Connections Setting: [Note: This option is not available in the Lite Edition]

This option is for sending data to OpusWare through its LiveSupport features.

  • SMTP Address: You should enter your SMTP address here. SMTP address is the outgoing email server, this address should be provided to you from your ISP (Internet Service Provider)

  • Port Address: Port address for SMTP server. Normally, it should be 25.

  • Connection time out: Time out for connecting to SMTP server. Its default value is 5 sec.


Testing Modules
-Testing Modules:

Testing modules are the heart of Hot CPU Tester. They have special instructions which test different components of system. Each testing module runs in a separate isolated thread (a sub-process). The testing modules intentionally overload all components to the maximum limits to exhibit their integrity. Unstable parts cannot endure these pressures and soon they will fail the tests. The program should run for several hours to check the system. 12 hours should be enough. If a system is stable under hard conditions ,say for 12 hours, it is not likely to generate error under normal conditions. However, for systems with critical tasks, for instance servers, 24 hours is more recommended.

Testing Modules descriptions:
  • Complex Matrix
    Complex Matrix is one of the modules which are specifically designed for testing the CPU. It overloads the CPU, by doing several mathematics functions. This module is very useful for finding mathematical flaws and errors, and specially, for testing overclocked CPU, and/or maximizing heat production.

  • Calculating Pi
    Calculating Pi is one of the modules which are specifically designed testing the CPU. It calculate the Pi number by calculating through 10000 digits. This module is very mathematical intensive it goes as far as 1/100,000,000; therefore is very useful for finding mathematical flaws and errors, and specially, for testing overclocked CPU, and/or maximizing heat production.

  • QuickSort
    Sorts an a list of 100,000 numbers of floating point 32 bits through QuickSort algorithm. This Module is very CPU intensive and is very useful for finding mathematical flaws and errors, and specially, for testing overclocked CPU, and/or maximizing heat production.

  • Prime Test

    Finds first 10,000 prime numbers. This Module is very CPU intensive and is very useful for finding mathematical flaws and errors, and specially, for testing overclocked CPU, and/or maximizing heat production.

  • Chipset [Note: This module is not available in the Lite Edition]

    This module designed to test chipset and motherboard. It uses special instructions to test motherboard's chipset. This module is very useful for testing motherboard, system bus, memory bus, and also PCI & ISA bus.

  • L1 Cache [Note: This module is not available in the Lite Edition]
    This module tests L1 cache and its stability. It uses special functions & instructions to test L1 cache and its data integrity. Data integrity is a very important factor for overclocked CPUs. Sometimes, the CPU functions correctly, but L1 cache cannot keep up it works with CPU.

  • L2 Cache [Note: This module is not available in the Lite Edition]
    This module tests L2 cache and it's stability. Its uses special functions & instructions to test L2 cache and its data integrity. Data integrity is a very important factor for overclocked CPUs. Sometimes, the CPU functions correctly, but L1 cache cannot keep at working with CPU at high speed.

  • Memory
    This module tests memory interface. It does not test the whole RAM, but it tests memory bus, some parts of chipset, and the whole system that somehow is involved with the memory. This module is very important for overclocked system. Most of the times, it is the first part that fails.

  • Peripherals [Note: This module is not available in the Lite Edition]

    Test CPU, Memory, Hard drive, chipset, and all the components in between. This is a very useful module for testing overclocked systems, as transferring data between Hard drive to Memory is the first component that fails in an overclocked system.

  • MMX instructions

    This module tests MMX instructions and registers. Sometimes, MMX calculations could be the first part that cracks under pressure (i.e. overclocking). This Module is also very useful for maximizing heat production.

  • SSE instructions [Note: This module is not available in the Lite Edition]

    This module tests SSE instructions and registers. Sometimes, SSE calculations could be the first part that cracks under pressure (i.e. overclocking). This Module is also very useful for maximizing heat production.

  • 3DNow! instructions [Note: This module is not available in the Lite Edition]

    This module tests 3DNow! instructions and registers. Sometimes, 3DNow! calculations could be the first part that cracks under pressure (i.e. overclocking). This Module is also very useful for maximizing heat production.


How to order Hot CPU Tester Pro

How to order Hot CPU Tester Pro 3:

For your convenience, we have teamed up with eSellerate from MindVision to provide you with the industry's newest and fastest automatic registration system with the highest security.

We feel obligated to all our customers and guarantee them 100% convenience. If you have any concerns regarding purchase of Hot CPU Tester simply send us an email to sales@7byte.com

There are two options to purchase Hot CPU Tester Pro 3:

  1. Directly from Hot CPU Tester Lite through our integrated eSeller.
    Integrated eSeller is a revolutionary technique, which allows customers to purchase and register Pro version of Hot CPU Tester directly through Hot CPU Tester Lite(which is available for free to download).
    To purchase Hot CPU Tester Pro, press the "Register" button in the welcome menu of Hot CPU Tester Lite, from there you can enter your information and credit card number. After that it automatically downloads the Professional version, then it finalizes transaction and makes the actual purchase. This way it reduces all unexpected results to 0%. Then it installs the Professional version of Hot CPU Tester Pro on your system.
    This options is the fastest & easiest way to Register your version of Hot CPU Tester.
  2. Through eSellerate secured servers on the web. This is the conventional method to register your version of Hot CPU Tester Pro. You can purchase Hot CPU Tester Pro through our webstore by:
    Click here to purcahse Hot CPU Tester Pro from webstore.
  3. By Phone, for more information click here
  4. by Fax, for more information click here.

What happens after you ordered:

  • If you have ordered Hot CPU Tester Pro directly through Hot CPU Tester Lite, it automatically installs the Pro version, assign you a serial number, let you to print a receipt. In additional to that you will receive an email from 7Byte, containing your receipt and your Hot CPU Tester Pro serial number.
  • If you have ordered Hot CPU Tester Pro through our webstore, you will receive a link to download Hot CPU Tester Pro, and also you will receive an email from 7Byte containing your receipt and your Hot CPU Tester Pro serial number


Some tips

Some tips and precautions
For a hardware test to be useful several precautions need to be taken. Failure to take into account these factors may result in tests being misleading or other unwanted results.
  • Stop all other applications before running Hot CPU Tester. Hot CPU Tester can be run in the background, in low priority mode but it just doesn’t seem prudent to do any important work when you’re testing a computer to see if it will fail. In any case Hot CPU Tester will place such a load on the system that any other applications will run at a snails pace. Not having other applications running also frees up more RAM that can be used by the Memory test.
  • Back-up any important files before you start. Hot CPU Tester can simulate many days of typical office PC use in a few hours, this increases the risk of hardware failure. Note that the testing process itself doesn’t touch any existing files on the hard disk or floppy disk.
  • We recommends running Hot CPU Tester just after you install a PC for the first time, as this is the ideal time to find a problem. The PC will be still under warranty and you can’t lose any of your data (because you haven’t loaded any). Any disruption caused by a failure will be minimal.
  • Remember that Hot CPU Tester does not create problems in your hardware, it just helps you find them in a controlled manner. Hot CPU Tester doesn’t use any nasty programming tricks to try and make your hardware fail. It uses the same functions and procedures that standard Windows applications and file servers use. If your computer fails when running Hot CPU Tester, it was going to fail in the near future anyway !
  • If you only want to test a particular component of the computer, turn the other tests off.
  • Doing a successful test run doesn’t mean that the computer will never fail. Software problems, viruses, and the fact that no computer component has an unlimited life span means that precautions need to be taken. Having good Hot CPU Tester results is NOT a substitute for making good file backups in the future.- On some new computers, the warranty may be voided if you open up the case. Check your warranty before you start poking around in the case.
  • Old computers tend to fill up with dust over the period of many years. This dust layer can cause heat build up and even short circuits. Check for dust build-up in old computers before you start.
  • Check the computer has adequate ventilation & check all the fans are in good working order.
  • Check that the computer isn’t full of bugs. (i.e. the insect type). Depending on where you live, insects can be a real problem. The term ‘Computer Bug’ was coined after a dead moth was found to have shorted out one of the first computers build.
  • There are many cases where a software bug may appear to be a problem with the hardware. Knowing who or what to blame isn’t easy. Check with your hardware manufacturer(s) from time to time in case they have released new software that fixes some problems they may have found. The hardware components that in general have the most problems with their, ‘Driver’ software are, Video cards (especially the 3D functions), Sound cards and CD ROMs.
  • Because of limitations in the memory test, faulty RAM errors may not be picked up by the test and faulty RAM can often manifest itself in different ways. These include disk I/O errors, system crashes and lockups.


Frequently Asked Questions (F.A.Q)

1. What is Hot CPU Tester?
Hot CPU Tester is a stability testing utility. It is a burn in test utility. It tests system for defective parts and system stability.

2. What are "Modules" in Hot CPU Tester?
A module is a testing unit, which tests system and its components. Modules are the heart of Hot CPU Tester. Each module runs a particular through test on the system. Hot CPU Tester is a multi-threaded program therefore, each module runs in a separate isolated thread. In other words all modules simultaneously runs on the system together, this way it loads system to its maximum limits and tests it under hard conditions to ensure every component is working in perfect harmony and stability with the system.

3. My system fails Hot CPU Tester but my computer is "completely stable" and runs flawless, why?
Hot CPU Tester tests systems thoroughly, and sometimes a system that "seems" stable has hidden problems that might not occur during normal usage. However, Hot CPU Tester can detect these problems through its unique DefectTech engine.

4. What is DefectTech?
DefectTech is a unique new technology designed by 7Byte to test components accurately. It can detect all potential errors on the system.

5. What is CPU Performance?
CPU Performance is a percentage which compares CPU speed while its under full load with its idle load. This number does not measure CPUs quality nor its stability. Note, that this number is relatively low on some AMD CPUs.

6. When I run Hot CPU Tester it says unable to find OLEACC.DLL file. What should I do?
OLEACC.DLL is a 'Windows Accessibility' library file. If you get that error message it means you don't have Windows Accessibility installed. Just install 'Windows Accessiblity' feature.

7. What is the difference between Hot CPU Tester Pro 3 & the Lite edition?
Basically, the Lite edition is a free version of Hot CPU Tester Pro, with some limitations. Hot CPU Tester Pro 3 has more testing modules and also you can get full technical support through LiveSupport.

8. What would I get if I buy Hot CPU Tester Pro 3?
- Chipset testing module
- L1 cache testing module
- L2 cache testing module
- Peripherals testing module
- Memory testing module
- SSE testing module
- Full technical support through our LiveSupport support systems
- Free updates
- 50% discount on our future products

9. How can I buy Hot CPU Tester Pro?
You have 2 options for buying Hot CPU Tester Pro.
a. Through our integrated eSeller. It is revolutionary system we use for your convenience. Simply, you can buy Hot CPU Tester Pro through Hot CPU Tester lite (free version) Just click on it, enter your information, and it automatically installs Hot CPU Tester Pro. It is very secure, and all of your information would be secured through cutting edge technology before they transfer through internet.
b. Through our WebStore it is the traditional way. just go to our WebStore, enter your information and then you will get a link to download Hot CPU Tester Pro.
If you have any concerns or questions please send an email to sales@7byte.com

10. How secure is your registration/transaction system?
For your convenience we have teamed up with eSellerate from MindVision to provide you with the industry's state of the art automatic registration system with the highest security. We have chosen eSellerate as our partners because, they are the most reliable in the industry. We use the latest encryption technology for transferring your data through the internet, and we also do not store your credit card numbers. We feel obligated to all our customers, and we guarantee your satisfaction, if you have any concerns or questions regarding buying Hot CPU Tester Pro just send us an email to sales@7byte.com

For all questions, concerns and inquiries send us an email to
info@7byte.com